1С-Предприятие 8.0. Практическое пособие разработчика


         

Прежде всего, создадим обработчик события




















Узнай больше!

О событиях, связанных с формой, можно прочитать в главе "События, связанные с формой" на странице 547.











Прежде всего, создадим обработчик события "ПриИзмененииСсылки", в котором установим требуемый нам отбор:











Процедура ПриИзмененииСсылки(ПутьКДанным)

   Cвойства.Отбор.HaбopCвойств.Установить(Cсылка,"Истина");

КонецПроцедуры



Затем в тело модуля формы добавим вызов этого обработчика:











ПодключитьОбработчикИзмененияДанных("СправочникОбъект.Ссылка", "ПриИзмененииСсылки"); [270]



И в заключение нужно предусмотреть возможность того, что пользователь может начать задавать новые значения свойств, не записав еще сам элемент справочника "НаборыСвойств".

Поэтому создадим обработчик события табличного поля "ПередНачаломДобавления":











Процедура СвойстваПередНачаломДобавления(Элемент, Отказ, Копирование)

   Если ЭтоНовый() Тогда

       Записать();

   КонецЕсли;

КонецПроцедуры




Содержание  Назад  Вперед