1С-Предприятие 8.0. Практическое пособие разработчика



         

Создание плана обмена Филиалы - часть 2


Процедура ПередЗаписью(Отказ)

   РегистрацияВНовыйУзел = ЭтоНовый();

КонецПроцедуры [404]

Этот обработчик и будет устанавливать значение нашей служебной переменной в Истина, в случае записи нового узла плана обмена. После этого создадим обработчик события формы "ПриЗаписи":

Процедура ПриЗаписи(Отказ)

   Если РегистрацияВНовыйУзел Тогда

       //Регистрация изменений всех данных для узла

       ПланыОбмена.ЗарегистрироватьИзменения(Ссылка);

   КонецЕсли;

КонецПроцедуры

Событие формы "ПриЗаписи" возникает после записи объекта ПланОбменаОбъект.Филиалы, но до окончания транзакции. Именно в этот момент мы обращаемся к механизму регистрации изменений, вызывая метод менеджера планов обмена – ЗарегистрироватьИзменения(). В данном случае будут созданы записи регистрации изменений, предназначенные для пересылки в созданный нами узел, для всех объектов обмена, указанных в составе данного плана обмена.

В заключение, создадим обработчик события формы "ПередОткрытием" для того, чтобы запретить установку реквизита "Главный" для предопределенного узла, соответствующего данной информационной базе:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

   Если Ссылка = ПланыОбмена.Филиалы.ЭтотУзел() Тогда

       ЭлементыФормы.Главный.Доступность = Ложь;

   КонецЕсли;

КонецПроцедуры

В этой процедуре мы используем метод менеджера плана обмена ЭтотУзел(), который возвращает ссылку на узел плана обмена, соответствующий данной информационной базе.

На этом создание плана обмена завершено, и мы можем перейти непосредственно к созданию процедур обмена данными. [405]




Содержание  Назад  Вперед