1С-Предприятие 8.0. Практическое пособие разработчика


         

В модуле объекта вызвать процедуру


Пока Выборка.Следующий() Цикл

   Сообщить(Выборка);

КонецЦикла;

















//  СоздатьДокумент()





//Пример: Создать новый документ ПриходнаяНакладная

НовыйДокумент = Документы.ПриходнаяНакладная.СоздатьДокумент();

НовыйДокумент.Дата = ТекущаяДата();

НовыйДокумент.Склад = Справочники.Склады.Основной;

//Заполнить табличную часть

НоваяСтрокаТабличнойЧасти = НовыйДокумент.Материалы.Добавить();

НоваяСтрокаТабличнойЧасти.Материал = Справочники.Номенклатура.НайтиПоКоду(6);

НоваяСтрокаТабличнойЧасти.Количество = 10;

НоваяСтрокаТабличнойЧасти.Цена = 22.5;

НоваяСтрокаТабличнойЧасти.Сумма = 225;

НовыйДокумент.Записать(); [579]

















//  Ссылка





//Пример: В модуле объекта вызвать процедуру проверки заполнения реквизитов документа

Если Не ПроверитьЗаполнениеРеквизитов(ЭтотОбъект.Ссылка) Тогда

   Сообщить("Реквизиты документа не заполнены!");

КонецЕсли;

















//  ПолучитьОбъект()

//  Скопировать()





//Пример: Пометить документ на удаление

НенужныйДокумент = Документы.ОказаниеУслуги.НайтиПоНомеру(13).ПолучитьОбъект();

НенужныйДокумент.УстановитьПометкуУдаления(Истина);

















//  Ссылка





//Сформировать список ссылок на все документы ПриходнаяНакладная за

//текущий месяц

СписокНакладных = Новый СписокЗначений;

Выборка = Документы.ПриходнаяНакладная.Выбрать(НачалоМесяца(ТекущаяДата()),КонецМесяца(ТекущаяДата()));

Пока Выборка.Следующий() Цикл

   СписокНакладных.Добавить(Выборка.Ссылка);

КонецЦикла; [580]

















//  ПолучитьОбъект()





//Пример: Удалить все документы ПриходнаяНакладная

Выборка = Документы.ПриходнаяНакладная.Выбрать();

Пока Выборка.Следующий() Цикл

   Выборка.ПолучитьОбъект().Удалить();

КонецЦикла;




Содержание  Назад  Вперед