1С-Предприятие 8.0. Практическое пособие разработчика


         

В обработчике события нажатия следует


В обработчике события нажатия следует вызвать метод объекта документ Записать(), с первым параметром, равным РежимЗаписиДокумента.Запись. После этого нужно закрыть форму:











Процедура ЗаписатьБезПроведенияИЗакрыть(Кнопка)

   Записать(РежимЗаписиДокумента.Запись);

   Закрыть();

КонецПроцедуры



Как перебрать строки табличной части документа?

Табличная часть документа (так же, как и любого другого объекта конфигурации, обладающего табличными частями) представляет собой коллекцию значений, элементами которой являются строки табличной части. Поэтому перебор строк табличной части (так же, как и любой другой коллекции значений) проще всего реализовать с помощью цикла Для Каждого ... Из ... Цикл ... КонецЦикла:











Для Каждого ТекСтрокаМатериалы Из Материалы Цикл

   ОчереднаяСтрока = ТекСтрокаМатериалы;

   ...

КонецЦикла;



При этом переменной цикла "ТекСтрокаМатериалы" будет являться не номер строки, а вся строка как объект. Для получения номера строки следует использовать свойство НомерСтроки или добавить переменную и увеличивать ее в теле цикла. [628]

Для обхода табличной части можно использовать и обычный цикл Для ... По ... Цикл ... КонецЦикла, но необходимо помнить, что индекс первого элемента коллекции всегда равен нулю:











Для СчетчикЦикла = 0 По Материалы.Количество() - 1 Цикл

   ОчереднаяСтрока = Материалы[СчетчикЦикла];

   ...

КонецЦикла;



В качестве примера можно посмотреть главу "Способы работы с коллекцией" на странице 550, или обработчик события "ОбработкаПроведения" в модуле документа "ПриходнаяНакладная" в разделе "Создание движений документа ПриходнаяНакладная" на странице 89.

Есть ли в версии 8.0 подчиненные документы?

Нет, специального понятия "Подчиненные документы" в версии 8.0 не существует.

В версии 8.0 одни объекты (документы, элементы справочников, задачи и т.д.) могут являться основанием, для создания других объектов. Таким образом, документ может быть создан не только на основании другого документа, но и на основании, например, элемента справочника или бизнес-процесса.


Содержание  Назад  Вперед