1С-Предприятие 8.0. Практическое пособие разработчика



       Сервис телевизоров Котельники, vityaz. |   

Общие вопросы - часть 2


Пользователь может прервать работу модуля, только если в процессе выполнения модуля выполняется вызов процедуры глобального контекста "ОбработкаПрерыванияПользователя". Эта процедура проверяет, была ли нажата пользователем клавиша Ctrl+Break и прерывает работу модуля.

Следует отметить, что работа модуля будет прервана не всегда, а только в тех случаях, когда работа модуля была инициирована следующими действиями пользователя:

·нажатие кнопки в форме;
·выбор пункта меню или кнопки панели инструментов в форме;
·выбор пункта меню или кнопки панели инструментов интерфейса;
·действия, инициируемые обработчиками событий "Выбор" элементов управления.

Более подробную информацию можно найти на диске ИТС в статье "Особенности прерывания пользователем работы модуля".

Почему в типовой конфигурации я не могу отредактировать полученную печатную форму документа?

Печатные формы первичных документов в типовых конфигурациях защищены от изменений пользователем. Режим "Защита" установлен [613] средствами встроенного языка, и типовые конфигурации содержат настройку, позволяющую регулировать установку этого режима.

Следует заметить, что при включенной защите невозможно не только внесение изменений, но и копирование ячеек данного табличного документа.

Аналогичный подход использовался и в типовых конфигурациях версии 7.7 (например, в девятой редакции "Торговля и склад").

В программных модулях у меня не выделяется цветом все, что относится к глобальному контексту (свойства, методы...)?

Да, в версии 8.0 выделяются цветом только конструкции встроенного языка:

Процедура ... КонецПроцедуры,

Функция ... КонецФункции,

Возврат,

Попытка ... Исключение ... КонецПопытки,

Для ... По ... Цикл ... КонецЦикла,

Для Каждого ... Из ... Цикл ... КонецЦикла,

Пока ... Цикл ... КонецЦикла,

Если ... Тогда ... ИначеЕсли ... Иначе ... КонецЕсли,

Перейти,

Прервать,

Продолжить,

Новый,

Перем,

Выполнить,

конструкция "?".

Встроенные функции языка, свойства и методы глобального контекста не являются конструкциями встроенного языка и поэтому не выделяются цветом. [614]




Содержание  Назад  Вперед